Comparte en:

Se ha descubierto y corregido una vulnerabilidad de seguridad crítica en el popular software de código abierto para servidores de correo electrónico Exim, esta podría permitir que un atacante remoto simplemente bloquee o ejecute potencialmente código malicioso en los servidores de destino.

Los encargados del soporte de Exim lanzaron hoy una actualización de seguridad urgente, Exim versión 4.92.3, después de publicar una advertencia temprana hace dos días.

De esta manera se alertaba a los administradores de sistemas sobre sus próximos parches de seguridad, que afectan a todas las versiones del software del servidor de correo electrónico, desde 4.92 hasta la última versión 4.92.2.

Exim es un agente de transferencia de correo de código abierto (MTA) ampliamente utilizado, desarrollado para sistemas operativos tipo Unix como Linux, Mac OSX o Solaris, que actualmente ejecuta casi el 60 por ciento de los servidores de correo electrónico de Internet para enrutar, entregar y recibir mensajes de correo electrónico.

Nueva actualización de seguridad

Esta es la segunda vez en este mes que los encargados de Exim han lanzado una actualización de seguridad urgente. A principios de este mes, el equipo parchó una vulnerabilidad crítica de ejecución remota de código (CVE-2019-15846) en el software, la cual podría haber permitido a los atacantes remotos obtener acceso de nivel root al sistema.

La vulnerabilidad ha sido identificada como CVE-2019-16928 y fue descubierta por Jeremy Harris del equipo de desarrollo Exim; la vulnerabilidad es un problema de desbordamiento de búfer (corrupción de memoria) basado en el string_vformat, definido en el archivo string.c del componente EHLO Command Handler.

La falla de seguridad podría permitir a los atacantes remotos causar una condición de denegación de servicio (DoS) o ejecutar código arbitrario en un servidor de correo Exim específico, utilizando una línea especialmente diseñada en el comando EHLO con los permisos del usuario objetivo.

Según el aviso de Exim, un exploit de Prueba de Concepto actualmente conocido para esta vulnerabilidad permite bloquear el proceso Exim enviando una cadena larga en el comando EHLO, aunque otros comandos también podrían usarse para ejecutar potencialmente código arbitrario.

“El exploit actualmente conocido utiliza una cadena EHLO larga extraordinaria para bloquear el proceso de Exim, que está recibiendo el mensaje”, afirma el equipo de desarrolladores de Exim.

“Mientras que, en este modo de operación, Exim ya perdió sus privilegios, pueden existir otras rutas para llegar al código vulnerable”.

 

A mediados de año, Exim también parchó una grave vulnerabilidad de ejecución remota de comandos (CVE-2019-10149) en su software de correo electrónico, que fue explotada activamente por varios grupos de hackers para comprometer servidores vulnerables.

Medidas a tomar

Por lo tanto, se recomienda encarecidamente a los administradores de servidores que instalen la última versión de Exim 4.92.3 lo antes posible, ya que no existe una mitigación conocida para resolver este problema temporalmente.

El equipo también afirma que: “si no puedes instalar las versiones anteriores, debes solicitar a tu responsable de paquetes una versión que contenga la solución actualizada. A pedido y dependiendo de nuestros recursos, te ayudaremos a respaldar la solución”.

La actualización de seguridad está disponible por si la quieres descargar para distribuciones de Linux, incluidos Ubuntu , Arch Linux , FreeBSD , Debian y Fedora.




0 Comments

Deja un comentario